I know it might sound a bit dumb, but I think naming conventions are not used as often as they should. Some people even think they're useless! Setting up a good naming convention is something that does not take a lot of time but it can save a lot of time in the future, specially when it's time to export your assets.
Anyways, I think there is a slight difference between an Idle and a Loop.
An Idle is an animation where the character is doing nothing, i.e. he's waiting. The best example for this would be the animations on the character selection screens for most games. The character is just there, waiting to be selected. No major action is done, other than breathing (if needed). He can do other things, like scratch his head or something, just to break the idle and make it more alive. Below is an example from Torchlight...
Now, the main difference between an Idle and a Loop is that the latter can be any type of animation. A loop can be punch, a kick, a character balancing from a rope, etc. I guess a loop is more of a generic term than an Idle.
To explain myself, I'll give you an example. Let's say you have the following animations:
- A character standing
- A character walking
- A character hanging from an edge
If Idle is the same as Loop, then your naming convention could be:
- Standing: CharA_Standing_Idle
- Walking: CharA_Walking_Idle
- Hanging from the edge: CharA_Hanging_Idle
Personally, I'd prefer something like this:
- Standing: CharA_Idle_Loop
- Walking: CharA_Walking_Loop
- Hanging: CharA_Hanging_Loop
Most people would say that the first one (Idle_Loop) sounds repetitive, since the Idle is always a cycle animation. And it's true. You never animate an Idle as a one-shot. However, consistency is a big factor whenever there is more than one person working on a production area, so having the Loop with the Idle for the sole purpose of being consistent makes sense. It will also allow you to add different types of Idle animations, like:
- CharA_Idle_Heavy (like a heavy breathing)
Anyways, that's the way I would do it. Let me know if you agree or you don't (and why).
And one more thing: Try to avoid the Idle01, IdleBreaker03, Scratch35... Always add the type of action to the name, so you don't have to open the file to see what the animation is doing.